MARSfarm Version 1 - Internet Connectivity and Software Access - help

Background: We are a team of students learning at the Innovation Center with a MarsFARM Unit, we are using the team name, The Martians.

We’ve been having some trouble accessing the MARSfarm program. When we try to log in, It gives us this message (see below). I believe the MARSfarm staff we met with for training told us that it was a school-side issue but I wanted to get clarification and potentially a solution so we can monitor our plants.

Thank you,
The Martians

I love the team name! :rocket: :seedling: :broccoli:

  • I appreciate you sharing this error as there may be other schools in Tempe Union experiencing the same error. @DrDonnaJ
  • The fastest way to get into our software is going to be to have your district approve our website so you can sign in with Google.
    • You can do that by clicking request access and sending them the URL
    • That is the official way for us to fix this and what I recommend/see work for schools that have had the same error.
    • If they don’t answer in a few days, try emailing them at ‘’ CC me personally `’, as well as your teacher, and I will answer any questions that they ask.
  • We are exploring alternative methods of having you login via an alternative ‘backdoor’ method. It sounds like you all would be in favor of that idea so I’ll make note of that!
    • If you can confirm which units you’re using for me (check the white serial plate on the top panel, it should be something like MV1-0009 and MV1-0010) I can then provide you with a demo of this.
    • I can also give you a link to the Google Sheet where all the data is also being logged when they’re online.

P.S. Sorry it took me so long for anyone to get back to you - please tag me in your response so I’m sure to reply quickly! @InnovationCenter - like this.

@InnovationCenter just got this email from your districts IT department:


It sounds like you now have this error: [Connection Issues ]


I created a new organization for the student domain and then added MV1-0009 and the trial ‘Spring 2023 (MV1-0009) - Light_Intensity:300umol, Light_Duration:14hours, Temperature:78F, Irrigation:200ML’ which we created before shipping the equipment.

Two more pieces of good news:

  1. I can see your device on MQTT - which means that you are able to create a new trial whenever you want. Here’s a link to a video showing how to do that once you login to the web application:
  1. I see a thousand rows of sensor data in the Google Sheet for MV1-0009 The data is also making it into our database so you’ll be able to see it visualized through the charts in the web application as well as the photos it has been taking.

Here are a few photos as a teaser - looks like you had a seedling that passed away :(. @InnovationCenter did you fill the bottom reservoir yet and set up the irrigation system to automatically add water daily?


@Peter we are still unable to access the web app on our end, but it’s good that the data can get through to you. I’m not sure what the problem on our end is. It might still be an issue with the email domain we are trying to access the software through.

Do you have any ideas on how to help?
The Martians

1 Like

we are still getting the same “invalid login domain” error.

1 Like

Hey @InnovationCenter, sorry you still can’t get in. I need you to please confirm a few things for me so I can be sure I get you configured correctly.

  1. What are the serial numbers of your MV1s?
  2. Please upload a screenshot of the error, I need to see exactly what it says so I can verify what is wrong.
  3. Please confirm the domain of your email is ‘@stu.tempeunion’(dotorg).
  4. Please login to the web app using an email address that ends with @gmail(dotcom). You should definitely be able to get on it that way, especially if you’re using your phone or aren’t on the school’s Wi-Fi.

We want to get it ‘working’ in its simplest form so let’s try to get that figured out first - regardless of the account you use or whether your school is blocking our website. Once you’re able to do that I’m sure we’ll be able to get the rest figured out.


  1. The serial numbers are “MV1-0009” & “MV1-0010”
  2. Screenshot of the error:
  3. That is the correct domain
  4. I can get on the webapp that way but it doesn’t display data from our MV1s
1 Like

Thank you very much for the very detailed response - that’s exactly the information that I needed.

I believe I have identified the error in our configuration. Please try to login again and let me know if you see any different results. This is the first time we’ve had a school use the ‘stu’ prefix in a domain.

Please try again.

If for any reason, you STILL cannot login, please follow the steps I recorded in this video to provide me with the domain name that is being provided by Google once you login.

Thank you so much for your help!
we are now able to use the webapp!

1 Like

You made my day! That’s great to hear!

I believe that there are two devices at your school MV1-0009 and MV1-0010 - is that correct? Are they both on Wi-Fi? I am only seeing data on my side from #9 and #10 is still set up for your teacher to view (rather than using the ‘stu’ domain) - let me know if you want us to assign both units to you and if we can be of any assistance getting #10 online!

@Peter Neither of the MV1s are on wifi. We had trouble connecting to Wi-Fi on both modules prior.

0009 is on Ethernet.

Would that issue be fixed with the invalid login domain being fixed?

@Peter also I’ve heard from IT that we can only have one ethernet port on the student domain.

Uhg, unfortunately I have to be the bearer of some bad news…I can see on our backend that you tried to create a new trial today.
The device didn’t receive it though, because it’s no longer able to communicate with our ‘MQTT’ server - which is what we use to pass the ‘trial’ (based on the recipe you chose) to the device so it can save those settings. The weird part is though that I verified you were able to connect to the ‘MQTT’ server back on 10/16, and again on 10/26. Were you using Wi-Fi originally and then you switched to Ethernet?

Check this thread out if you have questions about pros/cons of ethernet/wifi and context about MV1 networking: MARSfarm Customer FAQ

Unfortunately, these are not related. So if what you are asking is can you go back to just using Wi-Fi now - the answer is yes.

Could you clarify what you mean by ‘student domain’? Do you mean your user credentials for when you login?

The good news is though that images, sensor data - all that’s coming through great! I see that you were able to set up your irrigation system this week - good idea! The pump should be running 240 ml of water every morning at about 9:05 AM. That being said, the seedlings look thirsty :grimacing: hopefully the 240ML will be enough to help them catch up over the weekend!

We have been using ethernet the whole time for MV1-0009. I don’t believe there’s a problem with that one. It would be nice to set up both on wifi though.

I tried to set up MV1-0010 on wifi today but had some issues with it namely there was only one SSID option and I don’t know what the passphrase to it is.

I think the issue with the trial might be that I hit the cancel button after creating the trial.

1 Like

@Peter We are trying to move MV1-0009 from Ethernet to WiFi and connect MV1-0010 to WiFi and we have encountered some issues.

  1. the option to log into WifiConnect is not available on any device we check

I’m not sure where to go from here,
do you have an ideas on what could be going wrong?

1 Like

@InnovationCenter We did figure out that issue, and your new SD cards with the updated software are in the mail and should be arriving this week! Sorry about the delay in replying.
Here is the USPS tracking number: 92001903332000300058082736

Hey @InnovationCenter Did you receive the new SD cards from @drew and get the new version (Strawberry) connected via Wi-Fi? Give us an update and we’ll do our best to help troubleshoot what might be going on.

We did receive the new SD cards and I believe they are installed (IT installed them) but we are still unable to connect to wifi